Tag - encapsulation

Global Configuration Commands

Global Configuration Commands

Command                                          Description

config-registerregister                     Alters the configuration register.

boot system location                       Specifies location to load IOS.

hostname hostname                         Changes the name of the Cisco router or switch.

banner motd char banner char           Creates a message of the day login banner.

ip host name ipaddress                    Configures a static mapping of a hostname to an IP address.

ip name-server ip                            Specifies a DNS server IP address for dynamic name resolution.

ip domain-lookup                                      Enables automatic name resolution.

ip domain-name                                        Assigns a domain name to a Cisco device.

global configuration commands

Securing the IOS

First and foremost, ensure that you physically secure access to your Cisco devices so that there are no intentional or unintentional disruptions or access to the device itself.

To secure user EXEC access to your console port:

Router(config)#lineconsole 0

Router ( conf ig – line )#login

Router(config-line)#passwordpassword

 

To secure user EXEC access to your aux port:

Router(config)#lineaux 0 Router ( conf ig – line )#login Router(config-line)#passwordpassword

To secure user EXEC access to all five Telnet lines:

Router(config)#linevty 0 4

Router ( conf ig – line )#login

Router(config-line)#passwordpassword

To secure access to privileged EXEC mode:

Router(config)#enablesecret password Router(config)#enablepassword password

Theenable secret global configuration command encrypts the password using a MD5 hash.If theenable secret andenable password commands are used at the same time, theenable secret password is used.

To encrypt the enable password and the line passwords, use the service password-encryptioncommand.

configuration commands

SSH

To secure terminal access to the Cisco device, use SSH over Telnet. The steps to configure SSH are as follows:

  1. Configure a hostname on the device other than the default hostname.
  2. Configure a domain name for the Cisco device.
  3. Generate an RSA key (recommended to be at least 1024 bits) with the crypto key generate command.
  4. Create a username/password combination with the username username password password command.
  5. (Optional) Limit the vty lines to allow SSH with only the transportinput SSH command.

 

Interface Configuration Commands

 

Command                             Description

ip address ipsubnetmask    Assigns an IP address to an interface.

no shutdown                            Administratively enables an interface.

full-duplex

clock rate speed                     Sets the timing speed of the network on a DCE interface in bps.

bandwidth speed                   Sets the logical bandwidth setting for routing protocols in Kbps. ip address dhcp

Switch Commands

 Switch Configuration Commands

Command                                 Description

interface range media range Configures several interfaces with the same paramvcers.

ip address ipaddress               Assigns an IP address to a VLAN interface.

ip default -gateway ip Sets the gateway of last resort for a Layer 2 switch. Changes the speed of an autosensing link in Mbps. Sets the duplex of a switchport.

The copy Command

Thecopy command is used to copy files from one location to another. For example, to save the current configuration, we copy the running-config in RAM to the startup-config in NVRAM using the copy running-configstartup-configcommand.

Thecopy command is used to copy files between our device and a TFTP server. For instance,copy flashtftpbacks up the IOS in flash to a TFTP server.copy flashtftpcan be usedto upgrade, downgrade, or restore an IOS back onto our device. Before copying to a TFTP server, follow these steps:

  1. The TFTP server must have the TFTP service running.
  2. Our device must be cabled correctly. If a switch, plug the TFTP server into the switch with a straight-through Ethernet cable. If going directly between a router and the TFTP server, use a cross-over cable.
  3. You must have IP connectivity to the server.
  4. There must be enough room on the TFTP server and your device’s memory to store these files.

 

The show Command

  General show Commands
Command                                  Mode Output
show running-config              Privileged Current active configuration in RAM.
show startup-config               Privileged Configuration stored in NVRAM that is loaded on reboot.
show interfaces              User and privileged Status of the interfaces as well as physical and logicaladdress, encapsulation, bandwidth, reliability, load,MTU, duplex, broadcasts, collisions, and frame errors.

Status of the interfaces and their logical addresses.

Microcode of the interface including DCE/DTE cable

show ipinterfacebriefUser and privilegedshow controller               User and privileged
show flash                      User and privileged Filenames and sizes of IOS files stored in flash memory.
show version                  User and privileged IOS version, system uptime, amount of RAM, NVRAM,flash memory, and configuration register.

 

Interface Status

  Interface Status Values
Layer 1 Layer 2 (Line Protocol) Possible Symptoms
UpUp UpDown None. Interface is functional.Encapsulation mismatch, lack of clocking on serial
Down Down Cable is disconnected or attached to a shutdown inter‑face on the far-end device.
Administratively down Down Local interface was not enabled with the no shutdown

 

What is Frame Relay

Frame Relay is a WAN technology, it is used for communication. Frame relay is an industry standard, shared across, best effort, switch Data Link layer encapsulation that services multiple virtual circuits and protocols between connected mechanisms.

frame-relay-cloud

Frame Relay Terminologies:

1. Local-Access-Rate: 

Form 64- 2MB. It is a required bandwidth

2. Virtual Circuit

It is used for connection to a station

Types of VC:

  • PVC (Permanent Virtual Circuit)

           It is a dedicated line, which is used permanently

  • SVC (Switch Virtual Circuit)

           It is used when data is flowing.

3. Committed information Rate:

      Frame relay works by providing a portion of dedicated bandwidth to each user, and it also allows the user to exceed their guaranteed bandwidth if resources on the Telco network happen to be available. Frame Relay providers allow customers to buy a lower amount of bandwidth than what they really use.

 4. Data Link Connection Identifier:

It is a value which is used in virtual circuit.

5. Local Management Interface:

It is used to establish connection between Frame Relay switch and client router.

 Configuration of a Router in a Frame Relay environment:

  • Router(config)# int so
  • Router(config_if)# ip address 1.1.1.1 255.0.0.0
  • Router(cofnig_if)# encapsulation frame-relay
  • Router(config_if)# frame-relay lmi-type ansi
  • Router(config_if)# no shut
  • Router(config_if)# exit

Inter VLAN Routing

By default only hosts are member of the same VLAN can communicate. To change this and allow inter-vlan communication, we need a layer 3 switch or router. Or simply when we want to ping or access a computer which is on other vlan. so we have to place a router for inter routing.

routing

For this purpose we will logically divide the port of router in required parts and will assign IP to them which become the default gateway for both VLAN.

  • Switch# vlan database
  • Switch(vlan)# vlan 2 name IT
  • Switch(vlan)#vlan 3 name HR
  • Switch(vlan)# exit
  • Switch# conf t
  • Switch(config)# int range fa 0/1 – 8
  • Switch(conf_if)# switchport access vlan 2
  • Switch(conf_if)# exit
  • Switch(config)#int range fa 0/9 – 15
  • Switch(conf_if)# switchport access vlan 3
  • Switch(conf_if)# exit
  • Switch(conf)# int fa 0/24
  • Switch(conf)if)# switchport mode trunk
  • Switch(conf_if)# no shut
  • Switch(conf_if)# exit
  • Switch(conf)# exit
  • Now on router do the following configuration
  • Router>enable
  • Router# conf terminal
  • Router(conf)# int fa 0/0.1
  • Router(conf_if)# encapsulation dot1q 2
  • Router(conf_if)# IP address 192.168.10.1 255.255.255.0
  • Router(conf_if)# exit
  • Router(conf)# int fa 0/0.2
  • Router(conf_if)# encapsulation dot1q 3
  • Router(conf_if)# IP address 192.168.20.1 255.255.255.0
  • Router(conf_if)# exit
  • Router(conf)# int fa 0/0
  • Router(conf)if)# no shutdown

Copyright ©2010 - 2022 Ciscoforall.com | Privacy Policy | Terms & Conditions