Tag - Rip V2

Network Address Translation

Network Address Translation is used translate the private IP into Public IP. It is do mapping.

Types of NAT:

  1. Static NAT
  2. Dynamic NAT
  3. Overloading

1. Static Network Address Translation

It translate the one private IP into one Public IP, it also called 1-1 mapping

i.e. 192.168.10.1— 200.100.100.1

For Example:

LAN IP scheme is 192.168.10.0, and want to do nat for only one Private IP (192.168.10.1) to the one public IP 200.100.100.1

Public IP is 200.100.100.1

So Static NAT will be as

Static Network Address Translation

  • Router# conf terminal
  • Router(config)# int e0
  • Router(config_if)# ip add 192.168.10.10 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# exit
  • Router(config)# int s0
  • Router(config_if)# ip add 1.1.1.1 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# clock rate 6400
  • Router(config_if)# router rip

If we want to configure on RIP v2 so do as

  • Router(config_router)# version v2
  • Router(config_router)# network 192.168.10.10
  • Router(config_router)# network 1.0.0.0
  • Router(config_router)# exit
  • Router(config)# ip nat inside source static 192.168.10.1 200.100.100.1
  • Router(config)# int e0
  • Router(config_if)# ip nat inside
  • Router(config_if)# exit
  • Router(config_if)# int s0
  • Router(config_if)# ip nat outside
  • Router(config_if)# exit
  • Router(config)# exit
  • Router#

2. Dynamic Network Address Translation:

Dynamic NAT is used to translate the number of Private IP into the number of Public ip (ip pool)

For Example:

LAN IP scheme is: 192.168.10.0

Public Ip pool is: 200.100.100.1 200.100.100.10

Serial 0 ip is: 1.1.1.1

So the configuration will be as:

 Dynamic-Network-Address-Translation

 

  • Router# conf terminal
  • Router(config)# int e0
  • Router(config_if)# ip add 192.168.10.10 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# exit
  • Router(config)# int s0
  • Router(config_if)# ip add 1.1.1.1 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# clock rate 6400
  • Router(config_if)# router rip

If we want to configure on RIP v2 so do as

  • Router(config_router)# version v2
  • Router(config_router)# network 192.168.10.10
  • Router(config_router)# network 1.0.0.0
  • Router(config_router)# exit
  • Router(config)# ip nat pool mypool 1.1.10 1.1.1.20 netmask 255.0.0.0
  • Router(config)# ip nat inside source list 100 pool mypool
  • Router(config)# access-list 100 permit IP 192.168.10.0 0.0.0.255 any
  • Router(config)# int e0
  • Router(config_if)# ip nat inside
  • Router(config_if)# exit
  • Router(config)# int s0
  • Router(config)# ip nat outside
  • Router(config)#exit

3. Overload or Port Address Translation:

PAT or Overload NAT is used to do mapping to only one public IP for all the LAN IP.

For Example:

LAN IP scheme is: 192.168.10.0

Pubic IP is: 1.1.1.1 which is our S0

Overload or Port Address Translation

 

  • Router# conf terminal
  • Router(config)# int e0
  • Router(config_if)# ip add 192.168.10.10 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# exit
  • Router(config)# int s0
  • Router(config_if)# ip add 1.1.1.1 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# clock rate 6400
  • Router(config_if)# router rip

             If we want to configure on RIP v2 so do as

  • Router(config_router)# version v2
  • Router(config_router)# network 192.168.10.10
  • Router(config_router)# network 1.0.0.0
  • Router(config_router)# exit
  • Router(config)# ip nat inside source list 100 int so overload
  • Router(config)# access-list 100 permit ip 192.168.10.0 0.0.0.255 any
  • Router(config)# int e0
  • Router(config_if)# ip nat inside
  • Router(config_if)# exit
  • Router(config)# int s0
  • Router(config)# ip nat outside
  • Router(config)#exit

We can do overload in dynamic method as:

  • Router(config)# router rip
  • Router(config_router)# version v2
  • Router(config_router)# network 192.168.10.10
  • Router(config_router)# network 1.0.0.0
  • Router(config_router)# exit
  • Router(config)# ip nat pool mypool 1.1.1.1 1.1.1.1 netmask 255.0.0.0
  • Router(config)# ip nat inside source list 100 pool mypool overload
  • Router(config)# access-list 100 permit ip 192.168.10.0 0.0.0.255 any
  • Router(config)# int e0
  • Router(config_if)# ip nat inside
  • Router(config_if)# exit
  • Router(config)# int s0
  • Router(config)# ip nat outside
  • Router(config)#exit

 IOS (internetwork Operating System) Loading (Recovery and Backup) of Router:

Requirements:

  1. TFTP server (solar-wind TFTP server)
  2. A system connected with LAN for the purpose of TFTP software installation as

TFTP— Open it—File Configure

Select the 3rd option i.e. (Terminal and Replace…). It will make in a directory with name C:TFTP root in C: drive in that LAN system. Copy the IOS image file and paste in C:TFTP server directory. Now go to router and do the following configuration

  • Router# copy tftp flash
  • Router# ……… []? 10.0.0.10 (the TFTP server ip address)
  • Router#…………. []? Mc381-ismg.1207f (file name of IOS in backup)
  • Router#…………. []? Press Y. (confirmation message)
  • Router# reload

To take Backup of IOS to a system:

  • Router# copy flash tftp
  • Router# ……… []? 10.0.0.10 (the TFTP server ip address)
  • Router#…………. []? Mc381-ismg.1207f (file name of IOS in backup)
  • Router#…………. []? Press Y. (confirmation message)
  • Router#

Access Control List

Access control list is used for security on a Network from other Network. By this we restrict an IP or pool of IP to access a computer or a Network. And by the same way we can allow it to one system or no of system to access the system or network.

Type of ACL

  1. Standard ACL     (1-99)
  2. Extended ACL     (100-999)

Standard Access Control List:

It works on IP based packet filtering, to allow or deny a network of a specific computer on network. It is based on source IP. It work on priority base, when we put the permit condition first so first it will permit then will block the other IP.

Standard Access Control List

 

Configuration on Router 1

  • Router1# conf terminal
  • Router(config)# int e0
  • Router(config_if)# ip add 192.168.10.10 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# exit
  • Router(config)# int s0
  • Router(config_if)# ip add 1.1.1.1 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# clock rate 6400
  • Router(config_if)# router rip

If we want to configure on RIP v2 so do as

  • Router(config_router)# version v2
  • Router(config_router)# network 192.168.10.0
  • Router(config_router)# network 1.0.0.0
  • Router(config_router)# exit

To allow the traffic of Router 2, ip 192.168.20.1 on Router 1 and block the other

  • Router1(config)# Access-list 10 permit ip 192.168.20.1 0.0.0.0
  • Router1(config)# access-list 10 deny any
  • Router1(config)# int s0
  • Router1(config_if)# ip access-group 10 in
  • Router1(config_if)# exit

To allow all except 192.168.20.1 on Router 1

  • Router1(config)# access-list 10 deny ip 192.168.20.1 0.0.0.0
  • Router1(config)# access-list 10  permit any
  • Router1(config)# int s0
  • Router1(config_if)# ip access-group 10 in
  • Router1(config_if)# exit
  • Rotuer1(config)# exit
  • Router1#

 To allow 192.168.20.10   and     192.168.20.30 on Router1

  • Router1(config)# access-list 10 permit ip 192.168.20.10 0.0.0.0
  • Router1(config)# access-list 10 permit ip 192.168.20.30 0.0.0.0
  • Router1(config)# access-list 10 deny any
  • Router1(config)# int s0
  • Router1(config_if)# ip access-group 10 in
  • Router1(config_if)# exit
  • Rotuer1(config)# exit
  • Router1#

 To allow 1st 3 then block from 4-15 and then allow from 16-30 on Router 1

  • Router1(config)# access-list 10 permit ip 192.168.20.0 0.0.0.3
  • Router1(config)# access-list 10 deny ip 192.168.20.0 0.0.0.15
  • Router1(config)# access-list 10 permit ip 192.168.20.0 0.0.0.30
  • Router1(config)# int s0
  • Router1(config_if)# ip access-group 10 in
  • Router1(config_if)# exit
  • Rotuer1(config)# exit
  • Router1#

Now do the configuration on router 2 as

  • Router2> enable
  • Router# conf terminal
  • Router(config)#int e0
  • Router(config_if)# ip add 192.168.20.10 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# exit
  • Router(config)# int s0
  • Router(config_if)# ip add 1.1.1.2 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# clock rate 64000
  • Router(config_if)# exit
  • Router(config)# router rip  (for rip v2 just type version 2)
  • Router(config_router)# version 2
  • Router(config_router)# network 192.168.20.0
  • Router(config_router)# network 1.0.0.0
  • Router(config_router)# exit
  • Router(config)# exit
  • Router# exit

Type of ACL

  1. Standard ACL     (1-99)
  2. Extended ACL     (100-999

Router Basics Learn Step by Step

Router is layer 3 switch. It used for routing.

To Set Banner on Router:

  • Router>enable
  • Router# configure terminal
  • Router(config)# banner motd # Welcome To You #
  • Router(config)# exit
  • Router# exit

Welcome To You

  • Router>enable

Password recovery:

Password recovery is used to recover the password.

Note: the default registry value is “0x2102” remember.

Turn off the router

Turn on the router

Press Ctrl + page Break to enter

Rommon1> confreg 0x2141

Rommon2>reset

Router>enable

Router# conf terminal

Change or remove the password from console, privilege and vty mode

Router(conf)# configure-register 0x2102

Router(conf)# exit

Router# write mem                           to save the configuration

Cisco Router

 

Interfaces of Router:

  1. Ethernet 0 or Fast Ethernet 0/0:    this port is used to connect LAN through GJ-45 Straight cable.
  2. AUI (Attachment Unit Interface): it is used to connect LAN. Transceivers and straight cable is used for connecting LAN.
  3. Serial 0. 1: Serial 0 and Serial 1 is used to connect Router or External Modem with Router. V.35 Cable is used for connecting.
  4. Console port: Console port is used for configuration.

Routing Table:

  1.             Static routing table
  2.             Dynamic routing table

In Static routing the network administrator hand type the path for routing.

And in Dynamic routing a protocol on one router communicates with same protocol on another router to select path.

For Dynamic routing the following routing protocol is used.

  1. Distance Vector routing protocol
  2. Link state routing protocol
  3. Hybrid routing protocol

Distance Vector Routing Protocol:

Distance vector routing protocol work on Hope (no of Router) count method. It will select that path on which less no of router laying in the way to reach the destination.

Distance vector routing protocol are:

RIP RIP v2 and IGRP

Link state routing protocol:

It selects that path which is more reliable and have more band width. It also works on the selection of the shortest path to the destination not on number of router count.

Link state routing protocol is:

  • OSPF

Hybrid routing protocol:

Hybrid routing protocol work on both distance vector and link state. It also selects the shortest path and also number of hope router).

MORE:

Copyright ©2010 - 2021 Ciscoforall.com | Privacy Policy | Terms & Conditions

Porno Gratuit Porno Français Adulte XXX Brazzers Porn College Girls Film érotique Hard Porn Inceste Famille Porno Japonais Asiatique Jeunes Filles Porno Latin Brown Femmes Porn Mobile Porn Russe Porn Stars Porno Arabe Turc Porno caché Porno de qualité HD Porno Gratuit Porno Mature de Milf Porno Noir Regarder Porn Relations Lesbiennes Secrétaire de Bureau Porn Sexe en Groupe Sexe Gay Sexe Oral Vidéo Amateur Vidéo Anal