Tag - Routers

DHCP support and BOOTP

13. Can DHCP support statically defined addresses?

Yes. At least there is nothing in the protocol to preclude this and one expects it to be a feature of any DHCP server. This is really a server matter and the client should work either way. The RFC refers to this as manual allocation.

14. How does DHCP and BOOTP handle multiple subnets?

For the situations where there is more than one LAN, each with its own subnet number, there are two ways. First of all, you can set up a seperate server on each subnet. Secondly, a feature of some routers known as “BOOTP forwarding” to forward DHCP or BOOTP requests to a server on another subnet and to forward the replies back to the client. The part of such a router (or server acting as a router) that does this is called a “BOOTP forwarding agent”. Typically you have to enable it on the interface to the subnet to be served and have to configure it with the IP address of the DHCP or BOOTP server. On a Cisco router, the address is known as the “UDP Helper Address”.

Back DHCP FAQ

Dynamic Routing

RIP (routing information protocol) configuration forRIP v1 and RIP v2

 

dynamic routing

  • Router# conf terminal
  • Router(config)# int e0
  • Router(config_if)# ip add 192.168.10.10 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# exit
  • Router(config)# int s0
  • Router(config_if)# ip add 1.1.1.1 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# clock rate 6400
  • Router(config_if)# router rip

If we want to configure on RIP v2 so do as

  • Router(config_router)# version v2
  • Router(config_router)# network 192.168.10.0
  • Router(config_router)# network 1.0.0.0
  • Router(config_router)# exit

Now do the configuration on router 2 as

  • Router> enable
  • Router# conf terminal
  • Router(config)#int e0
  • Router(config_if)# ip add 192.168.20.10 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# exit
  • Router(config)# int s0
  • Router(config_if)# ip add 1.1.1.2 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# clock rate 64000
  • Router(config_if)# exit
  • Router(config)# router rip  (for rip v2 just type version 2)
  • Router(config_router)# version 2
  • Router(config_router)# network 192.168.20.0
  • Router(config_router)# network 1.0.0.0
  • Router(config_router)# exit
  • Router(config)# exit
  • Router# exit

If we have an environment in which there are 3 or more then 3 routers then the configuration will be  as

dynamic routing protocl

 

  • Router# conf terminal
  • Router(config)# int e0
  • Router(config_if)# ip add 192.168.10.10 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# exit
  • Router(config)# int s0
  • Router(config_if)# ip add 10.1.1.1 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# clock rate 6400
  • Router(config_if)# exit
  • Router(config)# router rip
  • If we want to configure on RIP v2 so do as
  • Router(config_router)# version v2
  • Router(config_router)# network 192.168.10.0
  • Router(config_router)# network 1.0.0.0
  • Router(config_router)# exit

Now do the configuration on router 2 as

  • Router> enable
  • Router# conf terminal
  • Router(config)#int e0
  • Router(config_if)# ip add 192.168.20.10 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# exit
  • Router(config)# int s0
  • Router(config_if)# ip add 1.1.1.2 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# clock rate 64000
  • Router(config_if)# exit
  • Router(config)# int s1
  • Router(config_if)# ip add 10.1.1.1 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# clock rate 64000
  • Router(config_if)# exit
  • Router(config)# router rip  (for rip v2 just type version 2)
  • Router(config_router)# version 2
  • Router(config_router)# network 192.168.20.0
  • Router(config_router)# network 1.0.0.0
  • Router(config_router)# network 10.0.0.0 (which is the network ID for 1.1.1.2 add)
  • Router(config_router)# exit
  • Router(config)# exit
  • Router# exit

Now configuration for router 3

  • Router> enable
  • Router# conf terminal
  • Router(config)#int e0
  • Router(config_if)# ip add 192.168.30.10 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# exit
  • Router(config)# int s0
  • Router(config_if)# ip add 10.1.1.2 255.255.255.0
  • Router(config_if)# no shut
  • Router(config_if)# clock rate 64000
  • Router(config_if)# exit
  • Router(config)# router rip 
  • Router(config_router)# version 2  (for rip v2 just type version 2)
  • Router(config_router)# network 192.168.30.0
  • Router(config_router)# network 1.0.0.0
  • Router(config_router)# network 10.0.0.0 (which is the network ID for 10.1.1.2 add)
  • Router(config_router)# exit
  • Router(config)# exit
  • Router# exit

MORE:

Difference between Distance vector and Link State protocol?

 Distance Vector Protocol :

  1. Entire routing table is sent as an update
  2. Distance vector protocol send periodic update at every 30 or 90 second
  3. Update are broadcasted
  4. Updates are sent to directly connected neighbor only
  5. Routers don’t have end to end visibility of entire network.
  6. Distance vector routing protocol network may have patch in network carrying wrong information
  7. It is proned to routing loops

distance-vector-and-link-state-routing-protocol

 Routing loop avoidance Mechanism used are as below :

  1.  Max Hop Count
  2. Spliti horizon
  3.  Route poisoning
  4.  Hold down Timer

Distance vector routing protocol has slow convergance due to periodic update. Eg. RIP ,IGRP , BGP .

Link state protocol :

  1. Updates are incremental & entire routing table is not sent as update
  2. Updates are triggered not periodic
  3. Updates are multicasted
  4. Update are sent to entire network & to just directly connected neighbor
  5. Updates are carry SPF tree information & SPF cost Calculation information of entire topology
  6. Routers have visibility of entire network of that area only.
  7. No routing loops
  8. Convergance is fast because of triggered updates.

Eg. : OSPF , IS-IS

Copyright ©2010 - 2021 Ciscoforall.com | Privacy Policy | Terms & Conditions

Porno Gratuit Porno Français Adulte XXX Brazzers Porn College Girls Film érotique Hard Porn Inceste Famille Porno Japonais Asiatique Jeunes Filles Porno Latin Brown Femmes Porn Mobile Porn Russe Porn Stars Porno Arabe Turc Porno caché Porno de qualité HD Porno Gratuit Porno Mature de Milf Porno Noir Regarder Porn Relations Lesbiennes Secrétaire de Bureau Porn Sexe en Groupe Sexe Gay Sexe Oral Vidéo Amateur Vidéo Anal